Current Service Status

BoB' Electronic Programme Guide (EPG) is experiencing slow performance Monday 11th March 2019 14:40:00


RESOLVED EPG performance issues have been resolved.

Update: 10:30 Hrs. BoB's EPG data is back.

Sorry, BoB's EPG is currently running a little slow. We have identified the issues and are working on restoring the EPG service.