Current Service Status

Authentication issues Wednesday 4th March 2020 15:30:00


Resolved: 16:45Hrs., this incident has been resolved and our service is stable.

Update: 15:56 Hrs., Service is now stable. We are monitoring closely for any further problems.

We are currently experiencing an outage with the authentication service and you might not be able to login.